El Capitan eller en hvilken som helst version af Mac OS X før 10.12.1 har et problem

12 oktober 2021 Skrevet af 
i Blogs
  • Skriftstørrelse
Bedøm denne artikel
(0 bedømmelser)

Hvis du stadig kører El Capitan eller en hvilken som helst version af Mac OS X før 10.12.1, så er du ved at støde på problemer med nogle populære sikkerhedscertifikater.

 

- Rigtigt mange website har i dag ssl certifikater fra LTE (LeTsEnCrypt) som skal opdateres med mellemrum hvor httpS - har udskiftet normal HTTP - hvor S betyder secure.
Konsekvensen er at mange Mac med ældre system ikke kan se en masse hjemmesider og der er kun få løsninger som betyder du skal opdatere og opgradere MacOSX.

Men rigtigt mange systemmer vil pludselig få problemer med at besøge hjemmesider og en rækkke programmer vil ikke virker.


Problemet er så at du skal altså mindt installere en version nyere end 10.12.1 - det nytter ikke at skifte fra Safari til Chrome fordi fejlen ligger dybere bagved i operativ systemet.

Faktisk har man kendt problemet siden 2019 men det berøre mest ældre MacOSx og man kan ikke bare opgradere til den nyeste version BigSur på alle maskiner.

Jeg prøvede på en maskine som sagde BigSur ikke kunne installeres på den aktuelle maskine og jeg prøvede forskellige udgaver og det lykkes så at opdatere til en High Sierra
som altså var nyere end 10.12.1.


En snyde metode quick/hack at man i google chrome henter filen  også installere man dette og fortæller at maskinen skal bare meget ukristisk acceptere et certificat fra den udbyder.

Men faktisk er også at google har valgt at sige man også SKAL ha nyere system end version 10.10 for google chrome opdatering men der er altså INGEN opdaterings mulighed på de ældre maskiner.

Man kan hente filen her https://letsencrypt.org/certs/isrgrootx1.pem

Jeg anbefaler ikke den hack løsning på længere sigt - man bør opgradere sit system eller måske installere Ubuntu Linux på sin gamle Mac hvis man ikke lige har programmer som er bundet til MacOSX.

En større opdatering af hele systemmet kan nemlig give store udfordringer med nogle programmer som efterfølgende også skal opdateres og måske geninstalleres hvor det kan være en lidt tidskrævende process.

 

 

Kan Linux erstatte Mac OS ?

Jeg benytter selv 100% Linux og oplever ingen begrænsninger og selv avanceret behov som video redigering er dækket hjem.
Faktisk syntes jeg MacOX er et meget lækkert system og jeg er blevet overrasket over hvor meget fra Unix/Linux som var på MacOSX speciel
hvis man installere Home Brew så har man mulighed for at installere en masse programmer fra Linux platformen.

Man kan også sige at selv Windows10 har fået WSL som giver tilsvarende adgang for at køre Linux programmer fordi en del af Linux kernen er på windows.
Det er praktisk hvis vi snakker om at programmer skal være tilgængelig på flere platforme.

 

64 Senest ændret Tirsdag, 12 oktober 2021 18:26
Mere i denne kategori: